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Introduction 

 
The KeeLogger™ Classic 

 

The KeeLogger™ Classic is an ultra-compact PS/2 hardware keylogger 
with 64 kB, 128 kB, or 256 kB of memory. All text data typed on the PS/2 
keyboard will be recorded to internal non-volatile memory. Recorded text 
data may be retrieved and analyzed on any other computer. This is done 
using software provided with the device: KeeLog Downloader Lite (for quick 
and easy playback), or KeeLog Downloader 3.0 (for advanced analysis). 
The device is 100% transparent for computer operation and no software or 
drivers are required for keystroke recording. 

 

Features 

 

• Ultra compact and discrete, only 1.6" (41 mm) long 

• Plug & Play install, no drivers required 

• Retrieve & Analyze software provided 

• Transparent to computer operation, undetectable for security 
scanners 

• Quick and easy national keyboard layout support 
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Applications 

 

Employers: 

• Monitor acceptable internet usage 

• Monitor employee productivity 

• Detect unauthorized access attempts 

• Backup typed text 

• Collect computer usage statistics 

 

Parents: 

• Monitor your family's computer activity 

• Protect your child from on-line hazards and predators 

• Observe WWW, E-mail, and chat usage 

• Save a copy of written documents 

 

Investigators: 

• Monitor remote computers 

• Retrieve unknown passwords, operating system independent 

• Collect computer-related evidence 

• Detect unauthorized use of computer equipment 

 

 

Requirements 

 

• record mode - any computer with standard PS/2 keyboard 

• playback mode - PC (min. Pentium 166 MHz) with Windows 
9X/ME/XP/2000 and standard PS/2 keyboard 
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Record Mode  

 

 
Installing the hardware keylogger in record mode is extremely simple. Plug 
it in between the keyboard and the PS/2 connector on the PC rear panel. 
The keylogger will automatically start recording all data typed on the 
keyboard. Previous data will not be overwritten, because recording will 
continue from the last used memory location. 
 

 
 
1. Find the PS/2 connector at the computer rear 
panel. 
 
 

 

 

2. Disconnect the keyboard. 
 
  

 

 

3. Connect the KeeLogger™ Classic in place of the 
keyboard. 
 
 

 

 

4. Connect the PS/2 keyboard to the hardware 
keylogger. On computer power-up the device will 
self-activate.  
 

 
Once the PC is powered, all data typed on the keyboard will automatically 
be recorded to the KeeLogger™ Classic internal memory. Logging will begin 
from last occupied position. Once the memory is full, logging will start over 
from the first memory position, in a circular way. 
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Playback Mode 
 

Once data has been acquired in record mode, you can transmit it to any 
other computer running Windows 9X/ME/XP/2000. There are two 
alternative applications for data retrieve and analysis:  
 

• KeeLog Downloader Lite - a simplified text-oriented application, 
quick and easy. Only standard mode is supported.  

• KeeLog Downloader 3.0 - the full download application with several 
modes of operation. Supports standard and Pro mode.  
 

Both versions are available on the CD-ROM attached with the device, and 
at the KeeLog website (http://www.keelog.com/). Installation requires 
administrator privileges (Windows 2000/XP). It is recommended to install 
KeeLog Downloader Lite when using the device for the first time. The 
hardware keylogger should be connected in the same way as in record 
mode. To initiate data transmission, type in the special password provided 
with the keyboard logger and press Enter. You will see the data being 
transmitted and displayed in the application main window.  
 
The images below summarize the data playback process. 
 
 

 
 

KeeLog Downloader Lite 

 
 

KeeLog Downloader 3.0 
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Type in the password supplied with the device and press Enter. Data 
download from the keyboard logger will occur automatically. Transmission 
can be stopped at any time by pressing a key. 
 

 
 

KeeLog Downloader Lite 

 
 

KeeLog Downloader 3.0 

 
Data can now be analyzed. You can use the applications automatic search 
options and save the log file. 
 

 

 
 

KeeLog Downloader Lite 

 
 

KeeLog Downloader 3.0 
 

 

The download process described above is only for the KeeLogger™ Classic 
set in standard mode. For enhanced mode operation, see the section 
Advanced Data Analysis (Pro mode). 
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Quick Data Analysis 

 
 
Data transmission from the 
keyboard logger to the 
computer can take up to 20 
minutes. However, you 
don't have to wait this long, 
as download can be finished 
at any time by pressing any 
key. This is usually the 
case, as the most recent 
data (usually the most 
interesting data too) is 
transmitted first. The longer 

 

you wait during transmission, the older the retrieved memory locations will 
be. When download is finished, you will be able to see raw data in the 
KeeLog Downloader main window. This window will contain keystroke data 
retrieved from the internal memory. Data may be analyzed manually by 
scrolling the window contents. 
 

 

 
If using KeeLog Downloader 3.0, the default 
data representation is a table, filled by 
keystroke data. An easier way for analyzing 
captured data is text mode: 
Tools->View as Text, or press the button 
Text View. 
This will show all typed and downloaded data 
as text, discarding special keys. You can 
save this data to a text file in form of a table 
or in text form with: 
File->Save as Table... or 
File->Save as Text...  
 
 

Another useful option is phrase search (Search->Find text...). This option 
will scan through downloaded data discarding special characters. This 
option is often used to quickly scan through the entire data log for phrases  
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entered in record mode. 
KeeLog Downloader 3.0 
also allows to quickly jump 
around the downloaded 
data. This includes jumping 
to the first and last 
memory location, as well   

 

as the first and last downloaded character. Use the options in the search 
menu (Search->Jump to...). 
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Mode Toggling 

 

 
The KeeLogger™ Classic is shipped in standard mode. Switching to Pro 
mode  will allow enhanced logging functionality, turning the device into an 
advanced PS/2 bus analyzer. In Pro mode special keys are recorded, such 
as Escape, F1...F12, Alt, Control, etc. Every PS/2 event is logged, including 
key-strokes, key-releases, and control characters. To switch to Pro mode, 
enter the supplied password and press Space. Once done, every data byte 
sent down the keyboard PS/2 line will be logged. Pro mode is not supported 
by KeeLog Downloader Lite. 
 
 
 
1. Plug the keylogger between the keyboard 
connector and the keyboard socket.  
 
 
  

 
 
2. To switch to Pro mode - run the KeeLog 
Downloader 3.0 application, enter the supplied 
password, and press Space. 
 
 
 

 
 

 

3. The logger will respond by sending a 
confirmation packet to the PC. The current mode 
is displayed in the KeeLog Downloader 3.0 status 
bar along with the device version. 
 
Repeat the described procedure to switch back to 
standard mode. 

 

 

 

 
It is highly recommended to erase the memory after mode toggling. The 
standard data format is not compatible with Pro data format, therefore 
memory areas occupied by both should not be mixed. See the section 
Memory Erasing. 
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Advanced Data Analysis (Pro Mode)  

 
The KeeLogger™ Classic operating in Pro mode will log every data byte 
sent down the PS/2 keyboard bus. This data can be later downloaded and 
analyzed by the KeeLog Downloader 3.0 application. It also provides 
information about every keyboard event in exact sequence, such as keys 
pressed, keys released, and control data. 
 
 
1. Plug the logger between the keyboard 
connector and the keyboard socket. 

 
 
 
2. Run the KeeLog Downloader 3.0 application, 
and type the password followed by Enter. 
 
 
 

 

 

 
 
3. Wait for the data transfer to end automatically, 
or press any key to terminate data download.  
 
 
 

 

 

 
4. Data can be saved, or translated. To translate 
click on Tools->Translate Raw Data. The 
translated data will show every event that took 
place on the keyboard line. 
 
 

 

 

 
 
5. Data can be further examined in the same 
way, as in standard mode. See section KeeLog 
Downloader 3.0 Features.  
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KeeLog Downloader 3.0 features 

 

 

Menu File 
 

New - reset program statistics, prepare for new 
download 

 

 

 

Save as Table... - save downloaded data to a text file in form of a table 
(similar to the main application table) 
Save as Text... - save downloaded data to a text file in text form (similar 
to the text view window) 
Load from Table... - load previously downloaded data from a table file 
Preferences - application preferences 
Interpret Shift keystrokes - enable interpretation of Shifts 
(recommended) 
Interpret Alt keystrokes - enable interpretation of Alt Gr 
(recommended for national keyboard layouts) 
Select Layout File... - select keyboard layout for national keyboards 
Select Language Path... - select path with alternate application 
language files 

Exit - exit application 
 
 

 

Menu Search 

 
Jump to first data downloaded - move table 
cursor to first downloaded character 
Jump to last data downloaded - move table 
cursor to last downloaded character 

 

 

 

Jump to last memory location - move table cursor to last location in 
KeeLogger™ internal memory 
Jump to first memory location - move table cursor to first location in 
KeeLogger™ internal memory 
Find text... – initiate text search dialog 
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Menu Tools 

 
View as text – view downloaded data in the text 
window, discarding special characters 
Translate raw data - convert keyboard bus data 
to text format (Pro mode only) 

 
 

 

Special key list – view list of keystroke abbreviations recognized by 
KeeLogger™ Classic 
Command list - view list of keyboard commands for KeeLogger™ Classic 
Search for E-mail/WWW addresses - search text data for E-mail and 
WWW addresses 
 
 

Menu Help 

 
KeeLog Downloader help... - initiate 
application help system  

 

 

About KeeLog Downloader... - display program information 
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Memory Erasing 
 

 

 
There is no actual need for memory erasing in the KeeLogger™ Classic, as 
the memory buffer works in a circular mode. This means, that once 
memory is full, logging will automatically start over from the first location. 
However, a special erase option exists, allowing complete hardware 
cleaning of the internal memory chip. 
  
To initiate memory contents erasing, connect the KeeLogger™ Classic to 
the PC (as in record mode) and run KeeLog Downloader 3.0 or KeeLog 
Downloader Lite. Type in the password supplied with the device, followed 
by Backspace. This will initiate memory cleaning, indicated on the computer 
by a special dialog. Do not disturb the computer while erasing. 
 

 

 
 
 
Memory erasing will take typically a few minutes (around 5 minutes for the 
64 kB version). After the erasing process finishes, the hardware keylogger 
will return to it’s initial state. Deleted data cannot be retrieved from the 
keyboard logger. 
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National Keyboard Options 

 
It is possible to enable a national layout for language-adapted 

keyboards, such as French, German etc. This will allow national characters 
to get logged properly (including those with Alt Gr), such as ö, æ, ß, ó etc. 
The following example demonstrates the advantages of applying the 
German national layout. 
 

Text logged without layout Text logged with layout 
 

KeyLogger (PS/2 & USB) 

 

Kezlogger )PS-2 / USB= 

 
To enable a national layout, select the keyboard layout which was used 
during data acquisition. 
 
KeeLog Downloader Lite: 
Options->Preferences->Select Layout File 
 
KeeLog Downloader 3.0 
File->Preferences->Select Layout File 

 

 

 

 

Command Summary 

 

 

password + <Enter>     ->  start download 

 

password + <Backspace> ->  erase memory 

 

password + <Space>     ->  toggle mode (Standard/Pro mode) 
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Specifications 

 
Power supply 
3.3 V-5.5 V DC (drawn from the PS/2 port)  
 
Power consumption 
25 mA  (0.13 W) 
 
Download speed 
1 kB/10s (approx.)  
 
Maximum burst log speed 
500 byte/s (approx.)  
 
Maximum continuous log speed 
100 byte/s (approx.)  
 
Dimensions (L x W x H) 
41 mm x 11 mm x 11 mm 
(1.6" x 0.4" x 0.4") 
 
 

 
 

Memory capacity 
64kB, 128kB, 256kB  
 
Data retention 

100 years  
 

Input/output  
PS/2 compatible keyboard 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

All KeeLog products come with 1 year warranty against manufacturer 
defects. Defect products must be shipped by the customer. All warranty 
repairs and delivery to the customer will be paid by KeeLog. 
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Troubleshooting  

 
The KeeLogger™ Classic will not work for the following hardware 
configurations:  
 

1. USB keyboards (even with PS/2 adapters)  

2. Non-PS/2 compatible keyboards 

3. Internal notebook keyboards  

4. Keyboards with coded transmission (requiring drivers) 

5. Some types of wireless keyboards and KVM switches (consult us first) 

 

 

Errors occur during KeeLog Downloader installation 

 

Windows 9X/NT/Me/2000/XP with administrator privileges and approx. 2MB 
of free disk space is required to install KeeLog Downloader 3.0/KeeLog 
Downloader Lite. 

 
 

The computer hangs when download is initiated 

 

Try the following in the order specified:  
 

1. Close all other applications besides KeeLog Downloader 3.0.  

2. Make sure KeeLog Downloader is the active application.  

3. Don't disturb the computer during transmission.  

 

If still you have problems with the download process, your system probably 
doesn't meet minimal requirements (Pentium 166 MHz) or too many 
background processes are active. Try the same on a faster PC. 
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Data download from the keylogger does not start 

 

Make sure you have done the following steps:  
 

1. Install the KeeLog Downloader 3.0 application.  

2. Connect the hardware keylogger.  

3. Connect the keyboard to the keylogger.  

4. Run the KeeLog Downloader 3.0 application.  

5. Type in the 8-character password to the application command line 
and press Enter (do not use upper case letters or the numeric 
keypad).  

 
This should start data download. You will see the data filling in the 
application main table. If this still didn't initiate data transmission:  
 

1. Check if you have selected the correct national keyboard layout  
(File->Preferences->Select Layout File...). 

2. Check if Caps Lock isn't active.  

3. Check if the device sits firmly in the PS/2 socket.  

4. Check if you are pressing Enter after the password.  

5. Check other features: memory erasing, mode toggling.  

6. Check if you have the correct password (do not use upper case letters 
or the numeric keypad).  

7. If using a non-standard keyboard, for example German (QWERTZ) or 
French (AZERTY), translate your password to standard keyboard 
layout (QWERTY).  

8. Disable any other applications running on your system.  

9. Restart KeeLog Downloader.  

 
If you still don't see the transmission process, open a text editor (such as 
Notepad), enter the password and press Enter. If download starts, then you 
probably have an invalid version of the KeeLog Downloader, or it is not the 
active application.  
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The keyboard does not respond in record mode 

 

The keyboard PS/2 connector or the keylogger PS/2 connector is not 
inserted firmly. Please check the connection with the PS/2 keyboard (purple 
color plug) and PS/2 port (purple color socket). 

 

Problems with logging national characters 

 

Please check if you have selected the correct national keyboard layout. If 
not, please read the National Keyboard Options section. 
 
 
 
I’ve checked everything, nothing helps! 

 
If you are still experiencing problems, please do the following: 
 

1. Check if the problem appears on a different keyboard. 

2. Check if the problem appears on a different computer. 

3. Contact us (keelog@keelog.com, http://www.keelog.com/). Please 
supply us all necessary information (keyboard model and 
manufacturer, OS type and version, and a short description of the 
problem). 
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Special Key List 

 

 

Standard mode 
 

Cap   -   Caps Lock 

Ent   -   Enter 

Bck   -   Backspace 

Num   -   Num Lock 

ShD   -   Shift pressed 

ShU   -   Shift released 

1 N   -   1 / End (numeric) 

 

2 N   -   2 / Down (numeric) 

3 N   -   3 / Page Down (numeric) 

4 N   -   4 / Left(numeric) 

5 N   -   5 (numeric) 

6 N   -   6 / Right (numeric) 

7 N   -   7 / Home (numeric) 

8 N   -   8 / Up (numeric) 

9 N   -   9 / Page Up (numeric) 

0 N   -   0 / Insert (numeric) 

. N   -   . / Delete (numeric) 
 

 

Pro mode 
 

Esc   -   Escape 

F1    -   F1 

F2    -   F2 

F3    -   F3 

F4    -   F4 

F5    -   F5 

F6    -   F6 

F7    -   F7 

F8    -   F8 

F9    -   F9 

F10   -   F10 

F11   -   F11 

F12   -   F12 

LCn   -   Left Control 

RCn   -   Right Control 

LAl   -   Left Alt 

RAl   -   Right Alt 

Ins   -   Insert 

Hom   -   Home 

PUp   -   Page Up 

PDn   -   Page Down 

Del   -   Delete 

Pwr   -   Power 

Slp   -   Sleep 

Wke   -   Wake 

Lwn   -   Left Win 

Rwn   -   Right Win 

Aps   -   Apps 

 

 

Prn   -   Print Screen 

End   -   End 

Scr   -   Scroll Lock 

Up    -   Up 

Dwn   -   Down 

Lft   -   Left 

Rgh   -   Right 

Cap   -   Caps Lock 

Ent   -   Enter 

Bck   -   Backspace 

Num   -   Num Lock 

Tab   -   Tabulator 

LSh   -   Left Shift 

RSh   -   Right Shift 

Spc   -   Space 

- N   -   - (num) 

+ N   -   + (num) 

EnN   -   Enter (num) 

. N   -   . / Delete (num) 

/ N   -   / (num) 

* N   -   * (num) 

0 N   -   0 / Insert (num) 

1 N   -   1 / End (num) 

2 N   -   2 / Down (num) 

3 N   -   3 / Page Down (num) 

4 N   -   4 / Left(num) 

5 N   -   5 (num) 

6 N   -   6 / Right (num) 

7 N   -   7 / Home (num) 

8 N   -   8 / Up (num) 

9 N   -   9/ Page Up (num) 
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Legal Disclaimer 
 

 

 

KeeLog does not take responsibility for any damage, harm or legal actions 
caused by misuse of it’s products. The user should follow the guidelines 
contained in this document, otherwise no liability will be assumed. It is the 
user's responsibility to obey all effective laws in his/her country, which may 
prohibit usage of KeeLog products. Please also consider, that not knowing 
the law does not allow to not obey it. A good example is the U.S. 
Department of Justice Letter on Keystroke Monitoring and Login Banners, 
according to which a clear notice should be displayed, warning that user 
keystrokes may be logged. Please check with your legal representative for 
logging requirements in your country. 
 
 

For more information on KeeLog products, visit our website:  
 

http://www.keelog.com/ 
 

 

 

 

 

 
 

You should not use this device to intercept  
data you are not authorized to possess,  

especially passwords, banking data,  
confidential correspondence etc. Most  

countries recognize this as a crime. Please  
consult a legal representative for logging 

requirements in your country. 
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Notes: 
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